Subscribe: spotlight-dev Mailing List
http://rss.lists.apple.com/spotlight-dev.rss
Preview: spotlight-dev Mailing List

spotlight-dev Mailing List



spotlight-dev Mailing List



Published: 2013-06-30T23:35:02-08:00

 



Re: creating temp files or temp folders in standard temp file locations on Mac OS X 10.8.3
From: Eric Slosser
Reply to list

I entered rdar://14081504 on this.  Do you have radar bug too?  I'll reference it in mine.    On Jun 7, 2013, at 7:22 PM, "Cianflone, Chris" <email@hidden> wrote:  




 Thanks for looking into this.  


 Just an FYI that we have opened a TSI on this. [...]



Re: creating temp files or temp folders in standard temp file locations on Mac OS X 10.8.3
From: Cianflone, Chris
Reply to list
Thanks for looking into this.  


 Just an FYI that we have opened a TSI on this.  I'll let you know the details once we sort this out with Apple. 

Thanks, 
Chris

On Jun 6, 2013, at 10:41 AM, "Eric Slosser" <email@hidden> wrote: 



 After a little more poking, I see the cause, the fix, and a workaround:


 cause:  In 10.8.3,  /usr/share/sandbox/mdworker.sb doesn't allow access to DARWIN_USER_TEMP_DIR 


 fix:

[...]

You can create your temp files in  DARWIN_USER_CACHE_DIR, importers have write access to that. 






 On Jun 5, 2013, at 4:03 PM, Eric Slosser <email@hidden> wrote: 



Chris, I get the same results as you.  Works on 10.7.5, doesn't work on 10.8.3.  It's a sandbox issue.


 In the Console, I see this:

[...]

When I click on the <Full Report> button, I get this:

[...]

On May 31, 2013, at 8:02 PM, "Cianflone, Chris" <email@hidden> wrote:

[...]



Re: creating temp files or temp folders in standard temp file locations on Mac OS X 10.8.3
From: Eric Slosser
Reply to list
After a little more poking, I see the cause, the fix, and a workaround:    cause:  In 10.8.3,  /usr/share/sandbox/mdworker.sb doesn't allow access to DARWIN_USER_TEMP_DIR     fix: > quoted text

[...]

workaround:  	You can create your temp files in  DARWIN_USER_CACHE_DIR, importers have write access to that.           On Jun 5, 2013, at 4:03 PM, Eric Slosser <email@hidden> wrote:   Chris, I get the same results as you.  Works on 10.7.5, doesn't work on 10.8.3.  It's a sandbox issue.    In the Console, I see this: > quoted text
    When I click on the <Full Report> button, I get this:     > quoted text
   On May 31, 2013, at 8:02 PM, "Cianflone, Chris" <email@hidden> wrote:  > quoted text